<!DOCTYPE html>
<html lang="en">
<head>
<META http-equiv="Content-Type" content="text/html; charset=UTF-8">
<title> Horoscope Today, April 2, 2022: Check astrological predictions for Cancer, Virgo, Pisces, Aries and other zodiac signs here</title>
<!--fixed-layout-->
<!--ls:begin[stylesheet]-->
<!--ls:end[stylesheet]-->
<!--ls:begin[meta-keywords]-->
<meta name="keywords" content="Horoscope Today April 02 2022,            Horoscope Today,             Horoscope April 02,             Taurus,             Cancer,             Virgo,             Capricorn,             Leo,             Libra,             Aries">
<!--ls:end[meta-keywords]-->
<!--ls:begin[meta-description]-->
<meta name="description" content="Horoscope Today  April 2  2022  If you are wondering how your Saturday will be then  scroll down and have a look at your daily horoscope ">
<!--ls:end[meta-description]-->
<!--ls:begin[custom-meta-data]-->
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<!--ls:end[custom-meta-data]-->
<!--ls:begin[meta-vpath]-->
<meta name="vpath" content="">
<!--ls:end[meta-vpath]-->
<!--ls:begin[meta-page-locale-name]-->
<meta name="page-locale-name" content="">
<!--ls:end[meta-page-locale-name]-->
<!--ls:begin[head-injection]--><script type="text/javascript">(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g; m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-60996559-1', 'auto',{'useAmpClientId':true}); ga('require', 'GTM-TFC6TDN');</script>
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer','GTM-5CTQK3');</script>
<script src="/Resources/englishjagran/js/common-header-footer.js"></script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<link rel="preconnect" href="//securepubads.g.doubleclick.net/tag/js/gpt.js" as="script" />
<meta property="fb:pages" content="187089557967784"/>
<link href="http://twitter.com" rel="preconnect">
<link href="http://twitter.com" rel="dns-prefetch">
<link href="https://www.youtube.com" rel="preconnect">
<link href="https://www.youtube.com" rel="dns-prefetch">
<link href="http://www.facebook.com" rel="preconnect">
<link href="http://www.facebook.com" rel="dns-prefetch">
<link href="https://cdn.ampproject.org" rel="preconnect">
<link href="https://cdn.ampproject.org" rel="dns-prefetch">
<link href="//www.doubleclickbygoogle.com" rel="preconnect">
<link href="//www.doubleclickbygoogle.com" rel="dns-prefetch">
<link href="//www.googleoptimize.com" rel="dns-prefetch">
<link href="//www.googleoptimize.com" rel="preconnect">
<link href="//www.googletagmanager.com" rel="dns-prefetch">
<link href="//www.googletagmanager.com" rel="preconnect">
<link href="//sb.scorecardresearch.com" rel="dns-prefetch">
<link href="//sb.scorecardresearch.com" rel="preconnect">
<link href="//b.scorecardresearch.com" rel="dns-prefetch">
<link href="//b.scorecardresearch.com" rel="preconnect">
<link href="//securepubads.g.doubleclick.net" rel="dns-prefetch">
<link href="//securepubads.g.doubleclick.net" rel="preconnect">
<link href="//pubads.g.doubleclick.net" rel="dns-prefetch">
<link href="//pubads.g.doubleclick.net" rel="preconnect">
<link href="//www.google-analytics.com" rel="dns-prefetch">
<link href="//www.google-analytics.com" rel="preconnect">
<link href="//www.googletagservices.com" rel="dns-prefetch">
<link href="//www.googletagservices.com" rel="preconnect">
<link href="//tpc.googlesyndication.com" rel="dns-prefetch">
<link href="//tpc.googlesyndication.com" rel="preconnect">
<link href="//ad.doubleclick.net" rel="dns-prefetch">
<link href="//ad.doubleclick.net" rel="preconnect">
<link href="//english.jagran.com" rel="dns-prefetch">
<link href="//english.jagran.com" rel="preconnect">
<link href="//imgeng.jagran.com" rel="dns-prefetch">
<link href="//imgeng.jagran.com" rel="preconnect">
<link rel="preload" href="/Resources/englishjagran/js/common-header-footer.js" as="script" />
<link rel="preload" href="/Resources/englishjagran/css/common-header-footer.css?ver=06052020" as="style" />
<link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin>
<link rel="preconnect" href="https://fonts.gstatic.com/s/nunito/v16/XRXW3I6Li01BKofAjsOUYevIWzgPDA.woff2" as="font" crossorigin>
<link rel="preconnect" href="https://fonts.gstatic.com/s/nunito/v16/XRXV3I6Li01BKofINeaBTMnFcQ.woff2" as="font" crossorigin>
<link rel="preconnect" href="https://fonts.gstatic.com/s/nunito/v16/XRXW3I6Li01BKofAksCUYevIWzgPDA.woff2" as="font" crossorigin>
<script>document.cookie = "__adblocker=; expires=Thu, 01 Jan 1970 00:00:00 GMT; path=/";var setNptTechAdblockerCookie = function(adblocker) {var d = new Date();d.setTime(d.getTime() + 60 * 5 * 1000); document.cookie = "__adblocker=" + (adblocker ? "true" : "false") + "; expires=" + d.toUTCString() + "; path=/";};var script = document.createElement("script");script.setAttribute("async", true);script.setAttribute("src", "//www.npttech.com/advertising.js");script.setAttribute("onerror","setNptTechAdblockerCookie(true);");document.getElementsByTagName("head")[0].appendChild(script);</script><script type="text/javascript"> var cX = cX || {}; cX.callQueue = cX.callQueue || []; cX.callQueue.push(['setSiteId', '2479549409819650741']); cX.callQueue.push(['sendPageViewEvent']); </script> <script type="application/ld+json">{"@context": "https://schema.org","@type": "BreadcrumbList","itemListElement": [{"@type": "ListItem","position": 1,"item": {"@id": "https://english.jagran.com","name": "News"}},{"@type": "ListItem","position": 2,"item": {"@id": "https://english.jagran.com/lifestyle","name":"Lifestyle"}}]}</script><meta property="og:site_name" content="Jagran English" />
<meta property="og:type" content="article" />
<meta property="og:title" content=" Horoscope Today, April 2, 2022: Check astrological predictions for Cancer, Virgo, Pisces, Aries and other zodiac signs here" />
<meta property="og:description" content="Horoscope Today  April 2  2022  If you are wondering how your Saturday will be then  scroll down and have a look at your daily horoscope " />
<meta property="og:image" content="https://imgeng.jagran.com/images/2022/apr/horoscope11648866675322.jpg" />
<meta property="og:url" content="https://english.jagran.com/lifestyle/horoscope-today-april-2-2022-check-astrological-predictions-for-cancer-virgo-pisces-aries-and-other-zodiac-signs-here-10041506" />
<meta property="twitter:card" content="summary_large_image" />
<meta property="twitter:site" content="@JagranEnglish" />
<meta property="twitter:creator" content="@JagranEnglish" />
<meta property="twitter:title" content=" Horoscope Today, April 2, 2022: Check astrological predictions for Cancer, Virgo, Pisces, Aries and other zodiac signs here" />
<meta property="twitter:url" content="https://english.jagran.com/lifestyle/horoscope-today-april-2-2022-check-astrological-predictions-for-cancer-virgo-pisces-aries-and-other-zodiac-signs-here-10041506" />
<meta property="twitter:description" content="Horoscope Today  April 2  2022  If you are wondering how your Saturday will be then  scroll down and have a look at your daily horoscope " />
<meta property="twitter:image" content="https://imgeng.jagran.com/images/2022/apr/horoscope11648866675322.jpg" />
<meta itemprop="name" content=" Horoscope Today, April 2, 2022: Check astrological predictions for Cancer, Virgo, Pisces, Aries and other zodiac signs here"><meta itemprop="description" content="Horoscope Today  April 2  2022  If you are wondering how your Saturday will be then  scroll down and have a look at your daily horoscope "><meta itemprop="image" content="https://imgeng.jagran.com/images/2022/apr/horoscope11648866675322.jpg"><meta itemprop="publisher" content="Jagran English"><meta itemprop="url" content="https://english.jagran.com/lifestyle/horoscope-today-april-2-2022-check-astrological-predictions-for-cancer-virgo-pisces-aries-and-other-zodiac-signs-here-10041506"><meta itemprop="editor" content="https://english.jagran.com/"><meta itemprop="headline" content=" Horoscope Today, April 2, 2022: Check astrological predictions for Cancer, Virgo, Pisces, Aries and other zodiac signs here"><meta itemprop="inLanguage" content="Hindi"><meta itemprop="sourceOrganization" content="Jagran English"><meta itemprop="keywords" content="Horoscope Today April 02 2022,           Horoscope Today,            Horoscope April 02,            Taurus,            Cancer,            Virgo,            Capricorn,            Leo,            Libra,            Aries"><meta itemprop="datePublished" content="2022-04-02T07:59:57+05:30+05:30"><meta itemprop="dateModified"  content="2022-04-02T07:59:57+05:30+05:30"><link rel="canonical" href="https://english.jagran.com/lifestyle/horoscope-today-april-2-2022-check-astrological-predictions-for-cancer-virgo-pisces-aries-and-other-zodiac-signs-here-10041506"/><link rel="amphtml" href="https://english.jagran.com/lite/lifestyle/horoscope-today-april-2-2022-check-astrological-predictions-for-cancer-virgo-pisces-aries-and-other-zodiac-signs-here-10041506"/><script type="application/ld+json">{"@context":"https://schema.org","@type":"NewsArticle","url":"https://english.jagran.com/lifestyle/horoscope-today-april-2-2022-check-astrological-predictions-for-cancer-virgo-pisces-aries-and-other-zodiac-signs-here-10041506","articleBody":"Horoscope Today  April 2  2022  If you are wondering how your Saturday will be then  scroll down and have a look at your daily horoscope ","articleSection":"Lifestyle","mainEntityOfPage":{"@type":"WebPage","@id":"https://english.jagran.com/lifestyle/horoscope-today-april-2-2022-check-astrological-predictions-for-cancer-virgo-pisces-aries-and-other-zodiac-signs-here-10041506"},"headline":" Horoscope Today, April 2, 2022: Check astrological predictions for Cancer, Virgo, Pisces, Aries and other zodiac signs here","description":"Horoscope Today  April 2  2022  If you are wondering how your Saturday will be then  scroll down and have a look at your daily horoscope ","datePublished":"2022-04-02T07:59:57+05:30","dateModified":"2022-04-02T07:59:57+05:30","image":{"@type":"ImageObject","url":"https://imgeng.jagran.com/images/2022/apr/horoscope11648866675322.jpg","height":800,"width":675},"author":{"@type":"Person","name":"Mallika Mehzabeen","url":"https://english.jagran.com/authors/mallika-mehzabeen"},"publisher":{"@type":"Organization","name":"Jagran English","logo":{"@type":"ImageObject","url":"https://imgeng.jagran.com/images/jagranenglish-logo-newone.png","width":600,"height":60 } } }</script><meta property="article:published_time" content="2022-04-02T07:59:57+05:30"/>
<meta property="article:modified_time" content="2022-04-02T07:59:57+05:30"/>
<!--ls:end[head-injection]--><!--ls:begin[tracker-injection]--><!--ls:end[tracker-injection]--><!--ls:begin[script]--><!--ls:end[script]--></head>
<body>
<!--ls:begin[body]--><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5CTQK3" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
 <script>var dataLayer = window.dataLayer || [];dataLayer.push({'event':'english_pageview','tvc_page_type':'Detail Page','tvc_publish_date':'2022-04-02T07:59:57','tvc_update_date':'2022-04-02T07:59:57','tvc_artical_tags':'Horoscope Today April 02 2022,           Horoscope Today,            Horoscope April 02,            Taurus,            Cancer,            Virgo,            Capricorn,            Leo,            Libra,            Aries','tvc_word_count':'481','tvc_page_cat':'lifestyle','link_present_home page':'true','tvc_author':'Mallika Mehzabeen','article_age':'3 hours ago','language':'English','genre':'Nation','author_ID':'Mallika Mehzabeen','tvc_detail_page':'Article Detail','storyID':'10041506','tvc_video_embed':'No','campaign':'none','online_offline':'Online','Embed_type':'none'});</script>
<div class="ls-canvas" id="ls-canvas">
<div class="ls-row" id="ls-row-1">
<div class="ls-fxr" id="ls-gen78625070-ls-fxr">
<div class="ls-area" id="ls-row-1-area-1">
<div class="ls-area-body" id="ls-gen78625071-ls-area-body">
<div class="ls-cmp-wrap ls-1st" id="w1591940230458">
<!--ls:begin[component-1591940230458]-->
<div class="iw_component" id="1591940230458"><style>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</style></div>
<!--ls:end[component-1591940230458]-->
</div>
<div class="ls-cmp-wrap" id="w1556360439801">
<!--ls:begin[component-1556360439801]-->
<div class="iw_component" id="1556360439801"><script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script><script>
function jsUcfirst(string){ return string.charAt(0).toUpperCase() + string.slice(1); }
function categoryName(){
	var pathname = window.location.pathname;
	var res = pathname.split("/");
	var catName = res[1];
	return jsUcfirst(catName);
}
var categoryNameURL = categoryName();
</script><script>
function getMetaKeywordsContent() {
 var metas = document.getElementsByTagName('meta');for (var i=0; i < metas.length; i++) {if (metas[i].getAttribute("name") == "keywords") {var value = metas[i].getAttribute("content").split(",").map(Function.prototype.call, String.prototype.trim);return value;}}return '';}
  googletag.cmd.push(function() {
   var widthWindow = $(window).width();
   if(widthWindow >= 1024){
    googletag.defineSlot('/13276288/Eng_Jagran/Desktop/'+categoryNameURL+'/detail/pagepush_980x50', [[980, 50], [728, 90], [980, 60], [980, 270]], 'ad_pagepush_980x50').addService(googletag.pubads());
    /*googletag.defineSlot('/13276288/Eng_Jagran/Desktop/'+categoryNameURL+'/detail/ticker_980x50', [[980, 60], [980, 50]], 'ad_ticker_980x50').addService(googletag.pubads());
    googletag.defineSlot('/13276288/Eng_Jagran/Desktop/'+categoryNameURL+'/detail/bottom_728x90', [728, 90], 'ad_bottom_728x90').addService(googletag.pubads());
	googletag.defineSlot('/13276288/Eng_Jagran/Desktop/'+categoryNameURL+'/detail/bottom_300x250', [[300, 600], [300, 250]], 'ad_bottom_300x250').addService(googletag.pubads());
	googletag.defineSlot('/13276288/Eng_Jagran/Desktop/Politics/detail/native_580x70', [160, 600], 'ad_native_580x70').addService(googletag.pubads());*/
    googletag.defineSlot('/13276288/Eng_Jagran/Desktop/'+categoryNameURL+'/detail/top_300x250', [[300, 250], [300, 200], [250, 250]], 'ad_top_300x250').addService(googletag.pubads());
    googletag.defineSlot('/13276288/Eng_Jagran/Desktop/'+categoryNameURL+'/detail/medium_300x250', [[300, 250], [300, 200], [250, 250]], 'ad_medium_300x250').addService(googletag.pubads());    
    googletag.defineSlot('/13276288/Eng_Jagran/Desktop/'+categoryNameURL+'/detail/lhs_160x600', [[160, 600], [120, 600]], 'ad_lhs_160x600').addService(googletag.pubads());
    googletag.defineSlot('/13276288/Eng_Jagran/Desktop/'+categoryNameURL+'/detail/rhs_160x600', [[160, 600], [120, 600]], 'ad_rhs_160x600').addService(googletag.pubads());	
	googletag.defineSlot('/13276288/Eng_Jagran/Desktop/'+categoryNameURL+'/detail/interstitial_1x1', [1, 1], 'ad_interstitial_1x1').addService(googletag.pubads());
	}
   else{
    googletag.defineSlot('/13276288/Eng_Jagran/Mobile/'+categoryNameURL+'/detail/top_300x250', [[300, 250], [336, 280], [300, 200], [250, 250]], 'ad_top_300x250_m').addService(googletag.pubads());
    googletag.defineSlot('/13276288/Eng_Jagran/Mobile/'+categoryNameURL+'/detail/medium_300x250', [[300, 250], [336, 280], [300, 200], [250, 250]], 'ad_medium_300x250_m').addService(googletag.pubads());
	googletag.defineSlot('/13276288/Eng_Jagran/Mobile/'+categoryNameURL+'/detail/bottom_300x250', [[300, 250], [336, 280], [300, 200], [250, 250]], 'ad_bottom_300x250_m').addService(googletag.pubads());
	/*googletag.defineSlot('/13276288/Eng_Jagran/Mobile/Politics/detail/native1_320x75', [[320, 75], [320, 50]], 'ad_native1_320x75_m').addService(googletag.pubads());
	googletag.defineSlot('/13276288/Eng_Jagran/Mobile/Politics/listing/native2_320x75', [[320, 75], [320, 50]], 'ad_native2_320x75_m').addService(googletag.pubads());*/
     googletag.defineSlot('/13276288/Eng_Jagran/Mobile/'+categoryNameURL+'/detail/interstitial_1x1', [1, 1], 'ad_interstitial_1x1').addService(googletag.pubads());	
   }
googletag.pubads().set("page_url", window.location.href);   
/*googletag.pubads().enableSingleRequest();*/
    googletag.pubads().collapseEmptyDivs();
    googletag.pubads().setTargeting('Category', []);
    googletag.enableServices();
  });
</script><script>
var widthWindow = $(window).width();
if(widthWindow < 1024){	
	window.googletag = window.googletag || { cmd: [] };
	googletag.cmd.push(function() {
	  var slot = googletag.defineOutOfPageSlot('/13276288/eng_jagran/mobile/'+categoryNameURL+'/detail/Interstitial_Vignette', googletag.enums.OutOfPageFormat.INTERSTITIAL, );
	  if (slot) slot.addService(googletag.pubads());
	  googletag.enableServices();
	  googletag.display(slot);
	});
}
</script>
</div>
<!--ls:end[component-1556360439801]-->
</div>
<div class="ls-cmp-wrap" id="w1554102400253">
<!--ls:begin[component-1554102400253]-->
<div class="iw_component" id="1554102400253"><link href="https://fonts.googleapis.com/css2?family=Nunito:wght@400;700;800&amp;display=optional" rel="stylesheet">
<link href="/Resources/englishjagran/css/common-header-footer.css?ver=06052021" rel="stylesheet"><script>
document.addEventListener("DOMContentLoaded", function(){
var imgE2 = document.getElementsByTagName('img');
for (var n=0; n < imgE2.length; n++) {
imgE2[n].setAttribute('width',imgE2[n].offsetWidth);
imgE2[n].setAttribute('height','100%');  
}
});
</script><script type="text/javascript">
	var _comscore = _comscore || [];
	_comscore.push({ c1: "2", c2: "13184768", cs_ucfr: "1" }); 
	(function() {
		var s = document.createElement("script"), el = document.getElementsByTagName("script")[0];s.async = true;
		s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b")+ ".scorecardresearch.com/beacon.js"; 
		el.parentNode.insertBefore(s, el); 
	})();
</script><header>
   <div class="header">
      <div class="menuNavigation">
         <div class="entryPointcommon"><a href="/india/coronavirus-live-news-tracker" title="English Jagran News">#Covid-19</a></div><a href="javascript:void()" title="close" class="menunav-close"></a><div class="topLinks menuLinks">
            <div class="container2">
               <section>
                  <div class="nav-raw">
                     <h3><a title="English Jagran News" href="/latest-news">Latest News</a></h3>
                     <ul></ul>
                  </div>
               </section>
               <section>
                  <div class="nav-raw">
                     <h3><a title="English Jagran News" href="/india">India</a></h3>
                     <ul></ul>
                  </div>
               </section>
               <section>
                  <div class="nav-raw">
                     <h3><a title="English Jagran News" href="/world">World</a></h3>
                     <ul></ul>
                  </div>
               </section>
               <section>
                  <div class="nav-raw">
                     <h3><a title="English Jagran News" href="/politics">Politics</a></h3>
                     <ul></ul>
                  </div>
               </section>
               <section>
                  <div class="nav-raw">
                     <h3><a title="English Jagran News" href="/education">Education</a></h3>
                     <ul></ul>
                  </div>
               </section>
               <section>
                  <div class="nav-raw">
                     <h3><a title="English Jagran News" href="/business">Business</a></h3>
                     <ul></ul>
                  </div>
               </section>
               <section>
                  <div class="nav-raw">
                     <h3><a title="English Jagran News" href="/technology">Technology</a></h3>
                     <ul></ul>
                  </div>
               </section>
               <section>
                  <div class="nav-raw">
                     <h3><a title="English Jagran News" href="/auto">Auto</a></h3>
                     <ul></ul>
                  </div>
               </section>
               <section>
                  <div class="nav-raw">
                     <h3><a title="English Jagran News" href="/lifestyle">Lifestyle</a></h3>
                     <ul></ul>
                  </div>
               </section>
               <section>
                  <div class="nav-raw">
                     <h3><a title="English Jagran News" href="/entertainment">Entertainment</a></h3>
                     <ul></ul>
                  </div>
               </section>
               <section>
                  <div class="nav-raw">
                     <h3><a title="English Jagran News" href="/tv">TV</a></h3>
                     <ul></ul>
                  </div>
               </section>
               <section>
                  <div class="nav-raw">
                     <h3><a title="English Jagran News" href="/photos">Photos</a></h3>
                     <ul></ul>
                  </div>
               </section>
               <section>
                  <div class="nav-raw">
                     <h3><a title="English Jagran News" href="/sports">Sports</a></h3>
                     <ul></ul>
                  </div>
               </section>
               <section>
                  <div class="nav-raw">
                     <h3><a title="English Jagran News" href="/cricket">Cricket</a></h3>
                     <ul></ul>
                  </div>
               </section>
               <section>
                  <div class="nav-raw">
                     <h3><a title="English Jagran News" href="/elections">Assembly Elections 2022</a></h3>
                     <ul>
                        <li><a title="English Jagran News" href="/elections/uttar-pradesh-assembly-elections?itm_source=jagranenglish&amp;itm_medium=banner&amp;itm_campaign=election-2022">Uttar Pradesh</a></li>
                        <li><a title="English Jagran News" href="/elections/uttarakhand-assembly-elections?itm_source=jagranenglish&amp;itm_medium=banner&amp;itm_campaign=election-2022">Uttarakhand</a></li>
                        <li><a title="English Jagran News" href="/elections/punjab-assembly-elections?itm_source=jagranenglish&amp;itm_medium=banner&amp;itm_campaign=election-2022">Punjab</a></li>
                        <li><a title="English Jagran News" href="/goa-assembly-elections?itm_source=jagranenglish&amp;itm_medium=banner&amp;itm_campaign=election-2022">Goa</a></li>
                        <li><a title="English Jagran News" href="/manipur-assembly-elections?itm_source=jagranenglish&amp;itm_medium=banner&amp;itm_campaign=election-2022">Manipur</a></li>
                     </ul>
                  </div>
               </section>
            </div>
         </div>
      </div>
      <div class="overlayBg"></div>
      <div class="container header-top">
         <div class="logo jagranlogo"><a href="/" title="English Jagran News"></a></div><span class="menuIcon menu"><small></small><small></small><small></small><b>Menu</b></span><div class="entryPointcommon"><a href="/india/coronavirus-live-news-tracker" title="English Jagran News">#Covid-19</a></div>
         <div class="hd-right fr">
            <div class="searchMobile fl"><a href="javascript:void()" title="Search" class="searchicon"></a></div>
            <div class="search fl headerSearch">
               <form method="post" action="/englishjagran/detailpages/article-detail.page?submit=true&amp;componentID=1554102400253" id="searchForm"><input id="searchText" type="text" name="searchText" aria-label="searchText" value="Type Your search" onBlur="if(this.value=='') this.value='Type Your search';" onFocus="if(this.value=='Type Your search') this.value='';"><input type="submit" value="" class="btnsrch" id="clickSearchValue1"></form>
            </div><span>Follow Us<small></small></span><ul class="social fl">
               <li class="fb"><a aria-label="Facebook" href="https://www.facebook.com/jagranenglishnews/" target="_blank" rel="nofollow noopener" title="Facebook"><i></i></a></li>
               <li class="tw"><a aria-label="Twitter" href="https://twitter.com/JagranEnglish" target="_blank" rel="nofollow noopener" title="Twitter"><i></i></a></li>
               <li class="in"><a aria-label="Linkedin" href="https://www.instagram.com/jagranenglishnews/" target="_blank" rel="nofollow noopener" title="Linkedin"><i></i></a></li>
            </ul>
         </div>
      </div>
      <div class="header-menu">
         <div class="top-strip"><b class="red"></b><b class="orange"></b><b class="l-orange"></b><b class="yellow"></b></div>
         <div class="container">
            <div id="mainNav" class="MainLMenu tab">
               <ul>
                  <li class="home" id="home"><a aria-label="Home" title="English Jagran News" href="/"><i></i></a></li>
                  <li><a title="English Jagran News" href="/latest-news">Latest News</a></li>
                  <li><a title="English Jagran News" href="/india">India</a></li>
                  <li><a title="English Jagran News" href="/cricket/ipl-news?itm_source=jagranenglishweb&amp;itm_medium=topnav&amp;itm_campaign=ipl-2022">IPL 2022</a></li>
                  <li><a title="English Jagran News" href="/topics/cryptocurrency?itm_source=web&amp;itm_medium=topnav&amp;itm_campaign=cryptocurrency">Cryptocurrency</a></li>
                  <li><a title="English Jagran News" href="/entertainment">Entertainment</a></li>
                  <li><a title="English Jagran News" href="/world">World</a></li>
                  <li><a title="English Jagran News" href="/politics">Politics</a></li>
                  <li><a title="English Jagran News" href="/business">Business</a></li>
                  <li><a title="English Jagran News" href="/lifestyle">Lifestyle</a></li>
                  <li><a title="English Jagran News" href="/education">Education</a></li>
                  <li><a title="English Jagran News" href="/technology">Technology</a></li>
                  <li><a title="English Jagran News" href="/cricket">Cricket</a></li>
                  <li class="mobileVishvasLogo"><a aria-label="Vishvasnews" href="https://www.vishvasnews.com/english/" target="_blank" rel="nofollow noopener" title="English Jagran News">Vishvas News</a></li>
               </ul>
            </div>
         </div>
      </div>
   </div>
</header><script>
   $(document).ready(function(){
	var wweight = $(window).width();
	if (wweight <= 1024){        
		$('.hd-right span').click(function(e){
			e.stopPropagation();
			$('.header .social').slideToggle();
		});
		$(document).click(function(){
			$('.header .social').slideUp();
		});
		$('.header .social').click(function(e){
			e.stopPropagation();
		});
	}
	
	$("#clickSearchValue1").click(function() {
		if($('#searchText').val() != 'Type Your search') {
			 var myStr =  $('#searchText').val();
			 myStr=myStr.replace(/(^\s+|[^a-zA-Z0-9\u0900-\u097F ]+|\s+$)/g,"");
			 myStr=myStr.replace(/\s+/g, "-");
			 window.location.href = '/search/'+myStr;
			 return false;
		}
	});
	$('#clickSearchValue1').prop('disabled', true);
	$('#searchText').keyup(function() {
	   if($(this).val() != '') {
	      $('#clickSearchValue1').prop('disabled', false);
	   }
	});	
  
  $(".searchicon").click(
      function(e){ 
   $(".searchicon").toggleClass("searchopen");
      e.stopPropagation();                                       
  $(".headerSearch").fadeToggle('slow');
   });
 $(".headerSearch").click(function(e){ e.stopPropagation(); });   
 $("body").click(function(){ 
$(".searchicon").removeClass("searchopen");
  $(".headerSearch").fadeOut("slow"); });
 }); 
  </script></div>
<!--ls:end[component-1554102400253]-->
</div>
<div class="ls-cmp-wrap" id="w1556360439802">
<!--ls:begin[component-1556360439802]-->
<div class="iw_component" id="1556360439802"><div style="position:relative;" class="eweb">
    <div class="gutter-banner"> 
        <!-- /13276288/jagran_ros_al_rhs_160x600 -->
        <div id='ad_rhs_160x600' style='height:600px; width:160px;'><script>googletag.cmd.push(function() { googletag.display('ad_rhs_160x600'); });</script></div>
        <div id="Jagran_ATD_D_rhs_160x600"></div>
    </div>
    <div class="gutter-banner gutter-banner-lhs">   
        <!-- /13276288/jagran_ros_ad_lhs_160x600 -->
        <div id='ad_lhs_160x600' style='height:600px; width:160px;'><script>googletag.cmd.push(function() { googletag.display('ad_lhs_160x600'); });</script></div>
        <div id="Jagran_ATD_D_lhs_160x600"></div>
    </div>
</div>
<style>
.gutter-banner{width:160px; height:600px; position:absolute; top:3px; right:0px; z-index:0;}
.gutter-banner-lhs{ left:0;}
@media(max-width:1266px){ .gutter-banner{display:none;}}
</style></div>
<!--ls:end[component-1556360439802]-->
</div>
</div>
</div>
<div class="ls-row-clr"></div>
</div>
</div>
<div class="ls-row container" id="ls-row-2">
<div class="ls-fxr" id="ls-gen78625072-ls-fxr">
<div class="ls-area" id="ls-row-2-area-1">
<div class="ls-area-body" id="ls-gen78625073-ls-area-body">
<div class="ls-cmp-wrap ls-1st" id="w1556360439803">
<!--ls:begin[component-1556360439803]-->
<div class="iw_component" id="1556360439803"><div class="adsBox eweb pagepush">
    <div id='ad_pagepush_980x50'>
        <script>googletag.cmd.push(function() { googletag.display('ad_pagepush_980x50'); });</script>
    </div>
</div></div>
<!--ls:end[component-1556360439803]-->
</div>
<div class="ls-cmp-wrap" id="w1571901820484">
<!--ls:begin[component-1571901820484]-->
<div class="iw_component" id="1571901820484">
</div>
<!--ls:end[component-1571901820484]-->
</div>
<div class="ls-cmp-wrap" id="w1554102400255">
<!--ls:begin[component-1554102400255]-->
<div class="iw_component" id="1554102400255"><section class="breadcrum">
<ul>
<li>
<a href="/"><strong>News</strong></a>
</li>
<li>&nbsp;&nbsp;&frasl;&nbsp;&nbsp;<a href="/lifestyle">Lifestyle</a>
</li>
</ul>
</section>
</div>
<!--ls:end[component-1554102400255]-->
</div>
</div>
</div>
<div class="ls-row-clr"></div>
</div>
</div>
<div class="ls-row container" id="ls-row-3">
<div class="ls-fxr" id="ls-gen78625074-ls-fxr">
<div class="ls-area socialLeft fl" id="ls-row-3-area-1">
<div class="ls-area-body" id="ls-gen78625075-ls-area-body">
<div class="ls-cmp-wrap ls-1st" id="w1554102400257">
<!--ls:begin[component-1554102400257]-->
<div class="iw_component" id="1554102400257"><div class="socialLeft fl">
<div id="socialLeft"></div>
</div>
</div>
<!--ls:end[component-1554102400257]-->
</div>
</div>
</div>
<div class="ls-area rightSection width600 fl" id="ls-row-3-area-2">
<div class="ls-area-body" id="ls-gen78625076-ls-area-body">
<div class="ls-cmp-wrap ls-1st" id="w1554102400258">
<!--ls:begin[component-1554102400258]-->
<div class="iw_component" id="1554102400258"><div id="topHeading">
<h1> Horoscope Today, April 2, 2022: Check astrological predictions for Cancer, Virgo, Pisces, Aries and other zodiac signs here</h1>
<div class="article-summery">Horoscope Today, April 2, 2022: If you are wondering how your Saturday will be then, scroll down and have a look at your daily horoscope.</div>
</div><article class="detailBox">
<div class="articleHd">
<div class="dateInfo">
<span class="fl">Publish Date: Sat, 02 Apr 2022 07:59 AM IST</span>
<div id="socialIconM">
<ul class="social">
<li class="fb">
<a rel="nofollow noopener" target="_blank" href="https://www.facebook.com/sharer.php?u=https://english.jagran.com/lifestyle/horoscope-today-april-2-2022-check-astrological-predictions-for-cancer-virgo-pisces-aries-and-other-zodiac-signs-here-10041506"><i></i>facebook</a>
</li>
<li class="tw">
<a rel="nofollow noopener" target="_blank" href="https://twitter.com/share?url=https://english.jagran.com/lifestyle/horoscope-today-april-2-2022-check-astrological-predictions-for-cancer-virgo-pisces-aries-and-other-zodiac-signs-here-10041506"><i></i>twitter</a>
</li>
<li class="wp">
<a target="_self" href="https://api.whatsapp.com/send?text=https://english.jagran.com/lifestyle/horoscope-today-april-2-2022-check-astrological-predictions-for-cancer-virgo-pisces-aries-and-other-zodiac-signs-here-10041506"><i></i>whatsapp </a>
</li>
<li class="em">
<a id="subscribe-sidebtn" onclick="window._izq.push([&quot;triggerPrompt&quot;]);" href="javascript:void()">subs</a>
</li>
</ul>
</div>
</div>
</div>
<figure class="bodySummery">
<img id="jagran_image_id" src="https://imgeng.jagran.com/images/2022/apr/horoscope11648866675322.jpg" alt=" Horoscope Today, April 2, 2022: Check astrological predictions for Cancer, Virgo, Pisces, Aries and other zodiac signs here" data-imgurl=" https://imgeng.jagran.com/images/2022/apr/horoscope11648866675322.jpg" data-src=" https://imgeng.jagran.com/images/2022/apr/horoscope11648866675322.jpg"></figure>
<div class="ads text-center">
<div class="emobile" id="ad_top_300x250_m">
<script>googletag.cmd.push(function() { googletag.display('ad_top_300x250_m'); });</script>
</div>
</div>
<div class="articleBody"><html>
 <head></head>
 <body>
  <p><strong>New Delhi | Jagran Lifestyle Desk:</strong> Astrological predictions help you to know your day in a better way. So, if you are wondering how your Saturday will be then, scroll down and have a look at your daily horoscope.</p>
  <div id="aniview"></div>
  <div class="adsBox adbox-interstitial">
   <div id="target-20"></div>
  </div> 
  <p><strong>Aries -</strong><span data-preserver-spaces="true">&nbsp;Today, you may feel restless and low. Remove negative thoughts from your mind. You will witness financial gains. You will receive money from unknown sources. You may face ideological differences with your spouse.</span></p> 
  <p><strong>Taurus -</strong><span data-preserver-spaces="true">&nbsp;Today is a good day as all your work will be completed on time. You will get cooperation and support from your office colleagues. You will remain stress-free throughout the day. Take care of your health and avoid junk food.&nbsp;</span></p> 
  <p><strong>Gemini -&nbsp;</strong><span data-preserver-spaces="true">The ongoing health problem will improve. You will be filled with enthusiasm. The work that has been stuck for a long time will be completed. However, you may face misunderstands in your family.&nbsp;</span></p> 
  <p><strong>Cancer -</strong><span data-preserver-spaces="true">&nbsp;Today, you will witness an increase in your confidence. However, do not take any big decisions in heat of the moment. You need to focus on your office work. Your religious interest will increase.</span></p> 
  <p><strong>Leo -&nbsp;</strong><span data-preserver-spaces="true">Today, you will maintain harmony in your personal and social life. Luck will be in your favour. Take care of your health and avoid eating junk food. There will be sweetness in the family.&nbsp;</span></p> 
  <p><strong>Virgo -</strong><span data-preserver-spaces="true">&nbsp;Today, you will remain happy. Your personal and professional relationships will improve. Be careful in money-related transactions. Hard work will bring success. You will get support from your family members in every matter.</span></p> 
  <p><strong>Libra -</strong><span data-preserver-spaces="true">&nbsp;Today, your financial situation will get better. You will be involved in social activities. Today is an auspicious day to invest in lands. There will be economic development. Family life will be happy.&nbsp;</span></p> 
  <p><strong>Scorpio -</strong><span data-preserver-spaces="true">&nbsp;Today, you will remain positive in every situation, and all your work will be completed easily. You will return the money that you have borrowed. Drive carefully as there is a risk of an accident.</span></p> 
  <p><strong>Sagittarius -</strong><span data-preserver-spaces="true">&nbsp;Today, you will feel lazy throughout the day. You will witness financial gains. Students will receive good news related to competitive exams. There will be unnecessary tension in the family. Be patient.</span></p> 
  <p><strong>Capricorn -</strong><span data-preserver-spaces="true">&nbsp;Today is your lucky day as you will complete all your work without any hurdles. You will witness financial gains. You will get support from your family.&nbsp;</span></p> 
  <p><strong>Aquarius -&nbsp;</strong><span data-preserver-spaces="true">Today is your hectic day as you have to work a lot. There are chances that you will travel due to work purposes. You will witness financial gains.&nbsp;</span></p> 
  <p><strong>Pisces -&nbsp;</strong><span data-preserver-spaces="true">Today, you will spend most of your time thinking about the future. You will focus on plans. You will also invest in properties. There will be peace and happiness in the family. Sweetness will increase between husband and wife. Be careful while driving.</span></p>
 </body>
</html><p style="margin: 20px 0 5px;">Posted By: 
							<strong><a href="/authors/mallika-mehzabeen">Mallika Mehzabeen</a></strong>
</p>
</div>
<div class="clearfix"></div>
<div class="jitengaBharatBanner eweb">
<a href="/cricket/ipl-news?itm_source=jagranenglishweb&amp;itm_medium=articledetail&amp;itm_campaign=ipl-2022" title="T20 News"><img src="https://imgeng.jagran.com/images/2022/mar/ipl-580x60-22032022.jpg" alt="T20 News"></a>
</div>
<div class="jitengaBharatBanner emobile">
<a href="/cricket/ipl-news?itm_source=jagranenglishweb&amp;itm_medium=articledetail&amp;itm_campaign=ipl-2022" title="T20 News"><img src="https://imgeng.jagran.com/images/2022/mar/ipl-300x50-22032022.jpg" alt="T20 News"></a>
</div>
<div class="clearfix"></div>
<div class="appendToThis"></div>
<div class="relatedReads">
<div class="h4">Related Reads</div>
<ul>
<li>
<a href="/lifestyle/world-autism-awareness-day-2022-what-is-autism-its-types-symptoms-and-treatment-10041497">World Autism Awareness Day 2022: What is autism? Know its types, symptoms..</a>
</li>
<li>
<a href="/lifestyle/world-autism-awareness-day-2022-know-history-significance-and-theme-for-this-day-10041488">World Autism Awareness Day 2022: Check history, significance and theme for..</a>
</li>
<li>
<a href="/lifestyle/chaitra-navratri-2022-wishes-messages-quotes-images-whatsapp-and-facebook-status-to-share-on-this-day-10041478">Chaitra Navratri 2022: Wishes, messages, quotes, images, WhatsApp and..</a>
</li>
</ul>
</div>
<div class="clearfix"></div>
<div class="ads emobile">
<div id="target-3"></div>
</div>
<div class="clearfix"></div>
<div id="article_container"></div>
</article><div class="tagList1" style="clear:both; overflow:hidden; height:1px; width:100%;"></div><script>
$(document).ready(function() {
	/*$('.realatedSreachtag .viewTags').click(function(){
		$('.realatedSreachtag').toggleClass('tagsOpen');
		$(this).hide();	         
	});
	$(".accordion_head").click(function() {
		$(this).parent().find(".arow-down").toggleClass("arow-up");
		if ($('.accordion_body').is(':visible')){
			$(".accordion_body").slideUp(300);
			$(this).parents().find(".arow-down").removeClass("arow-up");
		}
		if ($(this).next(".accordion_body").is(':visible')) {
			$(this).next(".accordion_body").slideUp(300);
			$(this).parent().find(".arow-down").removeClass("arow-up");
		}else{
			$(this).next(".accordion_body").slideDown(300);
			$(this).parent().find(".arow-down").addClass("arow-up");
		}
	}); */

	$(window).scroll(function(){
		var navpos1 = $('.tagList1').offset(); 
		var navpos = $('.articleHd').offset();
		if (($(window).scrollTop() > navpos.top) && ($(window).scrollTop() < navpos1.top)) {
	 		$('#socialLeft').addClass('note');
		}
		else {	 $('#socialLeft').removeClass('note');	}
	});
	var newHtml3=document.getElementById('socialIconM').innerHTML; $('#socialLeft').append(newHtml3); $('#socialIconM').remove(); 
	//var widthWindow=$(window).width();
	//if( widthWindow >= 980 ){		{ $('#mobileAppend').remove(); }	}

});

</script><div class="pianobox eweb" id="paywall"></div>
</div>
<!--ls:end[component-1554102400258]-->
</div>
</div>
</div>
<div class="ls-area leftSection width300 fr" id="ls-row-3-area-3">
<div class="ls-area-body" id="ls-gen78625077-ls-area-body">
<div class="ls-cmp-wrap ls-1st" id="w1556360439804">
<!--ls:begin[component-1556360439804]-->
<div class="iw_component" id="1556360439804"><div class="ads eweb top-300x250">
    <div id="ad_top_300x250">
    	<script>googletag.cmd.push(function() { googletag.display('ad_top_300x250'); });</script>
    </div>
</div></div>
<!--ls:end[component-1556360439804]-->
</div>
<div class="ls-cmp-wrap" id="w1637839483799">
<!--ls:begin[component-1637839483799]-->
<div class="iw_component" id="1637839483799"><style>#article_container, #article_container2 {clear: both; margin:20px 0; float:left; width:100%;}</style>
<div id="article_container2"></div>      
    </div>
<!--ls:end[component-1637839483799]-->
</div>
<div class="ls-cmp-wrap" id="w1582026960160">
<!--ls:begin[component-1582026960160]-->
<div class="iw_component" id="1582026960160"><article class="newsBox">
<div class="MainHd">
<h2>Top News</h2>
</div>
<ul class="commonList size1">
<li>
<figure>
<a href="/world/sri-lanka-economic-crisis-live-news-fuel-shortage-power-cuts-giotabaya-rajapaksa-emergency-declared-protests-curfew-latest-updates-10041510"><img data-src="https://imgeng.jagran.com/images/2022/apr/lanka1648872092132_m.jpg" alt="Sri Lanka declares state of emergency after violent protests over worsening economic crisis | Updates"></a>
</figure>
<span>World<small>
2 hours ago</small></span>
<div class="h3">
<a href="/world/sri-lanka-economic-crisis-live-news-fuel-shortage-power-cuts-giotabaya-rajapaksa-emergency-declared-protests-curfew-latest-updates-10041510">Sri Lanka declares state of emergency after violent protests over worsening economic crisis | Updates</a>
</div>
</li>
<li>
<figure>
<a href="/business/petrol-diesel-rates-hiked-again-10yth-rise-in-last-12-days-check-prices-in-delhi-noida-mumbai-other-cities-here-10041508"><img data-src="https://imgeng.jagran.com/images/2022/apr/petrol1648869933916_m.jpg" alt="Petrol, diesel rates hiked again, 10th rise in last 12 days; check prices in Delhi, Noida, Mumbai, other cities here"></a>
</figure>
<span>Business<small>
2 hours ago</small></span>
<div class="h3">
<a href="/business/petrol-diesel-rates-hiked-again-10yth-rise-in-last-12-days-check-prices-in-delhi-noida-mumbai-other-cities-here-10041508">Petrol, diesel rates hiked again, 10th rise in last 12 days; check prices in Delhi, Noida, Mumbai, other cities here</a>
</div>
</li>
<li>
<figure>
<a href="/india/prabhakar-sail-ncb-witness-in-aryan-khans-drugs-case-dies-of-heart-attack-family-rules-out-foul-play-10041512"><img data-src="https://imgeng.jagran.com/images/2022/apr/sail1648874526410_m.jpg" alt="Prabhakar Sail, NCB witness in Aryan Khan's drugs case, dies of heart attack; family rules out foul play"></a>
</figure>
<span>India<small>
1 hour ago</small></span>
<div class="h3">
<a href="/india/prabhakar-sail-ncb-witness-in-aryan-khans-drugs-case-dies-of-heart-attack-family-rules-out-foul-play-10041512">Prabhakar Sail, NCB witness in Aryan Khan's drugs case, dies of heart attack; family rules out foul play</a>
</div>
</li>
<li>
<figure>
<a href="/world/my-life-is-in-danger-opposition-planning-my-character-assassination-too-pak-pm-imran-khan-ahead-of-notrust-vote-10041505"><img data-src="https://imgeng.jagran.com/images/2022/apr/imran1648866617232_m.jpg" alt="'My life is in danger, opposition planning my character assassination too': Pak PM Imran Khan ahead of no-trust vote"></a>
</figure>
<span>World<small>
3 hours ago</small></span>
<div class="h3">
<a href="/world/my-life-is-in-danger-opposition-planning-my-character-assassination-too-pak-pm-imran-khan-ahead-of-notrust-vote-10041505">'My life is in danger, opposition planning my character assassination too': Pak PM Imran Khan ahead of no-trust vote</a>
</div>
</li>
<li>
<figure>
<a href="/education/cuet-2022-registration-process-for-ug-courses-in-central-universities-begins-on-april-2-heres-how-to-apply-10041507"><img data-src="https://imgeng.jagran.com/images/2022/apr/reg1648868034269_m.jpg" alt="CUET 2022: Registration process for UG courses in central universities begins today; here's how to apply"></a>
</figure>
<span>Education<small>
3 hours ago</small></span>
<div class="h3">
<a href="/education/cuet-2022-registration-process-for-ug-courses-in-central-universities-begins-on-april-2-heres-how-to-apply-10041507">CUET 2022: Registration process for UG courses in central universities begins today; here's how to apply</a>
</div>
</li>
<li>
<figure>
<a href="/entertainment/suhana-khan-abram-ananya-panday-scream-in-joy-as-kkr-thrash-punjab-kings-see-viral-pics-here-10041515"><img data-src="https://imgeng.jagran.com/images/2022/apr/su (2)1648876616381_m.jpg" alt="Suhana Khan, AbRam, Ananya Panday scream in joy as KKR thrash Punjab Kings | See viral pics here"></a>
</figure>
<span>Entertainment<small>
57 mins ago</small></span>
<div class="h3">
<a href="/entertainment/suhana-khan-abram-ananya-panday-scream-in-joy-as-kkr-thrash-punjab-kings-see-viral-pics-here-10041515">Suhana Khan, AbRam, Ananya Panday scream in joy as KKR thrash Punjab Kings | See viral pics here</a>
</div>
</li>
<li>
<figure>
<a href="/entertainment/disciplinary-proceedings-to-continue-academy-accepts-will-smiths-resignation-over-oscars-slapgate-10041513"><img data-src="https://imgeng.jagran.com/images/2022/apr/WillSmithResigns1648874700777_m.jpg" alt="'Disciplinary proceedings to continue': Academy accepts Will Smith's resignation over Oscars slapgate"></a>
</figure>
<span>Entertainment<small>
56 mins ago</small></span>
<div class="h3">
<a href="/entertainment/disciplinary-proceedings-to-continue-academy-accepts-will-smiths-resignation-over-oscars-slapgate-10041513">'Disciplinary proceedings to continue': Academy accepts Will Smith's resignation over Oscars slapgate</a>
</div>
</li>
</ul>
</article>
</div>
<!--ls:end[component-1582026960160]-->
</div>
<div class="ls-cmp-wrap" id="w1556360439805">
<!--ls:begin[component-1556360439805]-->
<div class="iw_component" id="1556360439805"><div class="ads eweb ad-height" id="target-1"></div>


</div>
<!--ls:end[component-1556360439805]-->
</div>
<div class="ls-cmp-wrap" id="w1556360439984">
<!--ls:begin[component-1556360439984]-->
<div class="iw_component" id="1556360439984"><article class="newsBox">
<div class="MainHd">
<h2>
<b>Latest </b> News</h2>
</div>
<ul class="commonList size1">
<li>
<figure>
<a href="/business/indian-railways-cancelled-trains-list-02-april2022-10041516"><img data-src="https://imgeng.jagran.com/images/2022/apr/irailway1648877177258_m.jpg" alt="Indian Railways cancel over 100 trains | Check complete list here "></a>
</figure>
<span>Business<small>44 mins ago</small></span>
<div class="h3">
<a href="/business/indian-railways-cancelled-trains-list-02-april2022-10041516">Indian Railways cancel over 100 trains | Check complete list here </a>
</div>
</li>
<li>
<figure>
<a href="/entertainment/disciplinary-proceedings-to-continue-academy-accepts-will-smiths-resignation-over-oscars-slapgate-10041513"><img data-src="https://imgeng.jagran.com/images/2022/apr/WillSmithResigns1648874700777_m.jpg" alt="'Disciplinary proceedings to continue': Academy accepts Will Smith's.."></a>
</figure>
<span>Entertainment<small>57 mins ago</small></span>
<div class="h3">
<a href="/entertainment/disciplinary-proceedings-to-continue-academy-accepts-will-smiths-resignation-over-oscars-slapgate-10041513">'Disciplinary proceedings to continue': Academy accepts Will Smith's..</a>
</div>
</li>
<li>
<figure>
<a href="/entertainment/suhana-khan-abram-ananya-panday-scream-in-joy-as-kkr-thrash-punjab-kings-see-viral-pics-here-10041515"><img data-src="https://imgeng.jagran.com/images/2022/apr/su (2)1648876616381_m.jpg" alt="Suhana Khan, AbRam, Ananya Panday scream in joy as KKR thrash Punjab Kings.."></a>
</figure>
<span>Entertainment<small>58 mins ago</small></span>
<div class="h3">
<a href="/entertainment/suhana-khan-abram-ananya-panday-scream-in-joy-as-kkr-thrash-punjab-kings-see-viral-pics-here-10041515">Suhana Khan, AbRam, Ananya Panday scream in joy as KKR thrash Punjab Kings..</a>
</div>
</li>
<li>
<figure>
<a href="/india/social-justice-reaches-delhi-annakalaignar-arivalayam-10041514"><img data-src="https://imgeng.jagran.com/images/2022/apr/stalin1648876259043_m.jpg" alt="Social Justice reaches Delhi - &lsquo;Anna-Kalaignar Arivalayam&rsquo;"></a>
</figure>
<span>India<small>1 hour ago</small></span>
<div class="h3">
<a href="/india/social-justice-reaches-delhi-annakalaignar-arivalayam-10041514">Social Justice reaches Delhi - &lsquo;Anna-Kalaignar Arivalayam&rsquo;</a>
</div>
</li>
<li>
<figure>
<a href="/india/prabhakar-sail-ncb-witness-in-aryan-khans-drugs-case-dies-of-heart-attack-family-rules-out-foul-play-10041512"><img data-src="https://imgeng.jagran.com/images/2022/apr/sail1648874526410_m.jpg" alt="Prabhakar Sail, NCB witness in Aryan Khan's drugs case, dies of heart.."></a>
</figure>
<span>India<small>1 hour ago</small></span>
<div class="h3">
<a href="/india/prabhakar-sail-ncb-witness-in-aryan-khans-drugs-case-dies-of-heart-attack-family-rules-out-foul-play-10041512">Prabhakar Sail, NCB witness in Aryan Khan's drugs case, dies of heart..</a>
</div>
</li>
</ul>
<div style="display: none;" class="latest_rhs_plttime_second">PLT IN SECOND = 0.002511701</div>
</article>
</div>
<!--ls:end[component-1556360439984]-->
</div>
<div class="ls-cmp-wrap" id="w1568801614324">
<!--ls:begin[component-1568801614324]-->
<div class="iw_component" id="1568801614324"><div id="M452919ScriptRootC401131"> <div id="M452919PreloadC401131"></div></div>

   
    </div>
<!--ls:end[component-1568801614324]-->
</div>
<div class="ls-cmp-wrap" id="w1556360439985">
<!--ls:begin[component-1556360439985]-->
<div class="iw_component" id="1556360439985"><div class="pianobox eweb" id="content_reco_1"></div><article class="newsBox">
<div class="MainHd">
<h2>
<b>Related</b> News</h2>
</div>
<ul class="commonList size1">
<li>
<figure>
<a href="/lifestyle/horoscope-today-april-2-2022-check-astrological-predictions-for-cancer-virgo-pisces-aries-and-other-zodiac-signs-here-10041506"><img data-src="https://imgeng.jagran.com/images/2022/apr/horoscope11648866675322_m.jpg" alt=" Horoscope Today, April 2, 2022: Check astrological predictions for.."></a>
</figure>
<span>Lifestyle<small>3 hours ago</small></span>
<div class="h3">
<a href="/lifestyle/horoscope-today-april-2-2022-check-astrological-predictions-for-cancer-virgo-pisces-aries-and-other-zodiac-signs-here-10041506"> Horoscope Today, April 2, 2022: Check astrological predictions for..</a>
</div>
</li>
<li>
<figure>
<a href="/lifestyle/chaitra-navratri-2022-know-about-the-significance-of-all-9-days-of-vasant-navratri-10041348"><img data-src="https://imgeng.jagran.com/images/2022/apr/ratri1648865301421_m.jpg" alt="Chaitra Navratri 2022: Know date, significance and importance of 9 days of.."></a>
</figure>
<span>Lifestyle<small>4 hours ago</small></span>
<div class="h3">
<a href="/lifestyle/chaitra-navratri-2022-know-about-the-significance-of-all-9-days-of-vasant-navratri-10041348">Chaitra Navratri 2022: Know date, significance and importance of 9 days of..</a>
</div>
</li>
<li>
<figure>
<a href="/lifestyle/chaitra-navratri-2022-know-about-date-time-and-puja-vidhi-of-kalash-sthapna-10041485"><img data-src="https://imgeng.jagran.com/images/2022/apr/cv1648865169029_m.jpg" alt="Chaitra Navratri 2022: Check date, time and puja vidhi of Kalash Sthapna"></a>
</figure>
<span>Lifestyle<small>4 hours ago</small></span>
<div class="h3">
<a href="/lifestyle/chaitra-navratri-2022-know-about-date-time-and-puja-vidhi-of-kalash-sthapna-10041485">Chaitra Navratri 2022: Check date, time and puja vidhi of Kalash Sthapna</a>
</div>
</li>
<li>
<figure>
<a href="/lifestyle/world-autism-awareness-day-2022-what-is-autism-its-types-symptoms-and-treatment-10041497"><img data-src="https://imgeng.jagran.com/images/2022/apr/waad1648864733124_m.jpg" alt="World Autism Awareness Day 2022: What is autism? Know its types, symptoms.."></a>
</figure>
<span>Lifestyle<small>4 hours ago</small></span>
<div class="h3">
<a href="/lifestyle/world-autism-awareness-day-2022-what-is-autism-its-types-symptoms-and-treatment-10041497">World Autism Awareness Day 2022: What is autism? Know its types, symptoms..</a>
</div>
</li>
<li>
<figure>
<a href="/lifestyle/world-autism-awareness-day-2022-know-history-significance-and-theme-for-this-day-10041488"><img data-src="https://imgeng.jagran.com/images/2022/apr/autism1648864570472_m.jpg" alt="World Autism Awareness Day 2022: Check history, significance and theme for.."></a>
</figure>
<span>Lifestyle<small>4 hours ago</small></span>
<div class="h3">
<a href="/lifestyle/world-autism-awareness-day-2022-know-history-significance-and-theme-for-this-day-10041488">World Autism Awareness Day 2022: Check history, significance and theme for..</a>
</div>
</li>
</ul>
<div style="display: none;" class="related_rhs_plttime_second">PLT IN SECOND = 0.002777254</div>
</article>
</div>
<!--ls:end[component-1556360439985]-->
</div>
</div>
</div>
<div class="ls-row-clr"></div>
</div>
</div>
<div class="ls-row" id="ls-row-4">
<div class="ls-fxr" id="ls-gen78625078-ls-fxr">
<div class="ls-area" id="ls-row-4-area-1">
<div class="ls-area-body" id="ls-gen78625079-ls-area-body">
<div class="ls-cmp-wrap ls-1st" id="w1554102400254">
<!--ls:begin[component-1554102400254]-->
<div class="iw_component" id="1554102400254"><div class="bottomLinks menuLinks">
   <div class="container">
      <div class="logo footerLogo fl"><a aria-label="Footer-Logo" href="/" class="flogo" title="English Jagran"><img data-src="https://imgeng.jagran.com/images/jagranenglish-logo-footer.png" alt="Jagran Logo" width="175"></a><ul class="hdr-topmenu">
            <li><a href="https://www.jagran.com/" target="_blank" rel="nofollow noopener" aria-label="Mid-Day" title="Hindi News">Hindi News</a></li>
            <li><a href="https://www.mid-day.com/" target="_blank" rel="nofollow noopener" aria-label="Mid-Day" title="Mid-Day">Mid-Day</a></li>
            <li><a href="https://www.onlymyhealth.com" target="_blank" rel="nofollow noopener" aria-label="Health" title="Health">Health</a></li>
            <li><a href="https://www.jagranjosh.com/" target="_blank" rel="nofollow noopener" aria-label="Education" title="Education">Education</a></li>
            <li><a href="https://www.naidunia.com/" target="_blank" rel="nofollow noopener" aria-label="Nai Dunia" title="Nai Dunia">Nai Dunia</a></li>
            <li><a href="https://www.inextlive.com/" target="_blank" rel="nofollow noopener" aria-label="Inextlive" title="Inextlive">Inextlive</a></li>
            <li><a href="https://www.herzindagi.com/" target="_blank" rel="nofollow noopener" aria-label="Her Zindagi" title="Her Zindagi">Her Zindagi</a></li>
            <li><a href="https://www.planetradiocity.com" target="_blank" rel="nofollow noopener" aria-label="Radio City" title="Radio City">Radio City</a></li>
            <li><a href="https://www.jagranjunction.com/" target="_blank" rel="nofollow noopener" aria-label="Blogs" title="Blogs">Blogs</a></li>
         </ul>
      </div>
      <div class="footerSocial  fr">
         <ul class="social">
            <li class="fb"><a aria-label="Facebook" title="Facebook" href="https://www.facebook.com/jagranenglishnews/" target="_blank" rel="nofollow noopener"><i></i></a></li>
            <li class="tw"><a aria-label="Twitter" title="Twitter" href="https://twitter.com/JagranEnglish" target="_blank" rel="nofollow noopener"><i></i></a></li>
            <li class="in"><a aria-label="Instagram" href="https://www.instagram.com/jagranenglishnews/" target="_blank" rel="nofollow noopener"><i></i></a></li>
         </ul>
      </div>
      <div class="footernav">
         <div class="fcopyright">
            <div class="fapplink eweb"><a href="https://bit.ly/3czpaQb" class="android-ioon" title="Download Android" target="_blank" rel="nofollow noopener"></a><a href="https://apple.co/3cyOea7" class="ios-ios" title="Download IOS" rel="nofollow noopener"></a></div>
            <div class="fapplink emobile"><a href="https://bit.ly/3bFj5k4" class="android-ioon" title="Download Android" target="_blank" rel="nofollow noopener"></a><a href="https://apple.co/2WvvvX8" class="ios-ios" title="Download IOS" target="_blank" rel="nofollow noopener"></a></div><span class="copytxt">Copyright © 2022 Jagran Prakashan Limited.</span><img data-src="https://imgeng.jagran.com/images/digital-cert.jpg" alt="ABC Digital CERTIFIED" class="digitalimg"></div>
         <ul>
            <li><a aria-label="About-Us" href="/about-us" title="About us">About us</a></li>
            <li><a aria-label="Advertise" href="/advertise-withus" title="Advertise">Advertise with Us</a></li>
            <li><a aria-label="Book Print Ad" rel="nofollow noopener" href="https://classifieds.jagran.com/bookads/" target="_blank" title="Book Print Ad">Book Print Ad</a></li>
            <li><a aria-label="Partnership" href="/advertise-withus" title="Partnership">Partnership</a></li>
            <li><a aria-label="Contact us" rel="nofollow noopener" href="https://jplcorp.in/JPLWeb/JPL_Enquiry.aspx" title="Contact us">Contact us</a></li>
            <li><a aria-label="Sitemap" href="/sitemap" title="Sitemap">Sitemap</a></li>
            <li><a aria-label="Privacy-Policy" href="/privacy-policy" title="Privacy Policy">Privacy Policy</a></li>
            <li><a aria-label="Disclaimer" href="/terms-conditions" title="Disclaimer">Disclaimer</a></li>
            <li><a aria-label="DNPA’s code" href="/dnpa-code-of-ethics-for-digital-news-websites" rel="nofollow" title="DNPA’s code">This website follows the DNPA’s code of conduct</a></li>
            <li><a rel="nofollow" href="mailto:compliant_gro@jagrannewmedia.com" title="feedback">For any feedback or complaint, email to compliant_gro@jagrannewmedia.com</a></li>
         </ul>
      </div>
   </div>
</div><script type="text/javascript">

$(document).ready(function() {
//If the 'hide cookie is not set we show the message
if (!readCookie('hide')) 
{ $('#gdprbx').show();}
// Add the event that closes the popup and sets the cookie that tells us to
// not show it again until one day has passed.
$('#close').click(function() 
{
$('#gdprbx').hide();
createCookie('hide', true, 60);
return false;
});

});
//And some generic cookie logic
function createCookie(name,value,days) {
if (days) {
var date = new Date();
date.setTime(date.getTime()+(days*24*60*60*1000));
var expires = "; expires="+date.toGMTString();
}
else var expires = "";
document.cookie = name+"="+value+expires+"; path=/";
}
function readCookie(name) {
var nameEQ = name + "=";
var ca = document.cookie.split(';');
for(var i=0;i < ca.length;i++) {
var c = ca[i];
while (c.charAt(0)==' ') c = c.substring(1,c.length);
if (c.indexOf(nameEQ) == 0) return c.substring(nameEQ.length,c.length);
}
return null;
}
var winwid = window.innerWidth;
if(winwid < 768){
function checkVisible1(e,i){i=i||"object visible";var o=$(window).height(),n=$(window).scrollTop(),c=$(e).offset().top-300,s=$(e).height();return"object visible"==i?c<o+n&&c>n-s:"above"==i?c<o+n:void 0}document.addEventListener("scroll",function(){checkVisible1($(".appendToThis"))&&$("#draggable").css("display","none")});} 
</script><div id="gdprbx">
   <div class="container">
      <div class="cookiebox">This website uses cookie or similar technologies, to enhance your browsing experience
         and provide personalised recommendations. By continuing to use our website, you agree
         to our <a href="https://english.jagran.com/privacy-policy" target="_blank" rel="noopener">Privacy Policy</a> and <a href="/cookie-policy.html" target="_blank" rel="noopener">Cookie Policy</a>.<a id="close" href="JavaScript:void()" class="close">OK</a></div>
   </div>
</div><style>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</style><div class="Cube" id="draggable">
   <div class="closebtn"></div>
   <div class="swiper-containerr Cubebox">
      <div class="swiper-wrapper">
         <div class="swiper-slide">
            <div class="contentBox"><a href="/india/coronavirus-live-news-tracker?itm_source=slide1&amp;itm_medium=cube&amp;itm_campaign=covid">
                  <h2>Vaccination</h2>
                  <div class="innerCont">
                     <h3>India</h3>
                     <p style="line-height: 11px; color: green;"><strong style="font-size: 9px; display: block;">Total Vaccination:</strong>1,84,31,89,377
                     </p>
                     <p style="line-height: 14px;"><strong style="line-height: 14px;">Active:</strong>13,672
                     </p>
                     <p style="line-height: 13px;"><strong style="line-height: 13px;">Deaths:</strong>5,21,181
                     </p>
                  </div></a></div>
         </div>
         <div class="swiper-slide">
            <div class="contentBox"><a href="/cricket/ipl-news?itm_source=slide2&amp;itm_medium=cube&amp;itm_campaign=ipl-2022" class="cube-savlonad secbanner" title="IPL News"></a></div>
         </div>
         <div class="swiper-slide">
            <div class="contentBox">
               <h2>COVID 19</h2>
               <div class="innerCont"><a href="/latest-news?itm_source=other&amp;itm_medium=cube&amp;itm_campaign=lnws" class="cube-latnws" title="latest news"></a></div>
            </div>
         </div>
         <div class="swiper-slide">
            <div class="contentBox"><a href="https://www.jagran.com/mahindra.html#regForm" title="latest news" target="_blank" class="cube-savlonad" rel="noopener"></a></div>
         </div>
      </div>
   </div><script data-src="/Resources/englishjagran/js/cube-jagran.js"></script></div>
<div class="pianobox eweb" id="bottom_ribbon"></div></div>
<!--ls:end[component-1554102400254]-->
</div>
<div class="ls-cmp-wrap" id="w1556360439808">
<!--ls:begin[component-1556360439808]-->
<div class="iw_component" id="1556360439808"><script>
function dislayDiv(){ if(document.getElementById('draggable')){document.getElementById('draggable').style.display="block";} }
/*$(document).ready(function(){
   //$(".articleBody p:nth-child(5)").prepend("<div class='adsBox emobile'><div id='target-2'>"+"</div></div>");
   //$(".articleBody p:nth-child(7)").prepend("<div class='adsBox emobile'><div id='target-3'>"+"</div></div>");
	//mobile web html removal
	if(widthWindow>=980){ $('.emobile').remove(); }
	else{ $('.eweb').remove(); }
});*/

var widthWindow=$(window).width();
var isScrolled = 0;
window.addEventListener('scroll', function() { 
$( ".articleBody script" ).each(function( index ) {
		$(this).attr('src',$(this).attr('data-src'));
		}); 
   checkAssets('jagrancss');
});  
function checkAssets(id) {
    return new Promise(function(resolve, reject) {
        if (document.getElementById(id)) {resolve(1);} 
		else {   
    if (id == 'jagrancss') {
    if(isScrolled == 0){		
	$('body').attr('id', 'jagrancss');
	isScrolled=1;   

     function showAds(showid, i){
     var para = document.createElement("script");
     var divbx = document.createElement("div");
     divbx.id=showid;
     var a = "googletag.cmd.push(function() { googletag.display('"+divbx.id+"'); });";
     var t = document.createTextNode(a);   
     para.appendChild(t);
     divbx.appendChild(para);   
     document.getElementById("target-"+i).appendChild(divbx);
       } 
	   
	   if(document.getElementById('target-1')){showAds('ad_medium_300x250', 1)};
	   //if(document.getElementById('target-2')){showAds('ad_bottom_300x250', 2)};
	   /*if(widthWindow>=1024){
			if(document.getElementById('target-3')){showAds('ad_bottom_728x90', 3)}
		}*/
	   if(document.getElementById('target-20')){showAds('ad_interstitial_1x1', 20)};
	   
	   var jagran_video_web = '<script async id="AV612f49564c3e630901196cec" type="text/javascript" src="https://tg1.aniview.com/api/adserver/spt?AV_TAGID=612f49564c3e630901196cec&AV_PUBLISHERID=600954c7a1167b792b178d04">' + '<' + '/script>';
	   
	   var jagran_video_mob = '<script async id="AV612f498791913517f47a1a3c" type="text/javascript" src="https://tg1.aniview.com/api/adserver/spt?AV_TAGID=612f498791913517f47a1a3c&AV_PUBLISHERID=600954c7a1167b792b178d04">' + '<' + '/script>';

	   
	   if(widthWindow < 1024){
			if(document.getElementById('target-2')){showAds('ad_medium_300x250_m', 2)}
			if(document.getElementById('target-3')){showAds('ad_bottom_300x250_m', 3)}
			$(".appendToThis").append(jagran_video_mob);
		}
		else{ 
			$(".appendToThis").append(jagran_video_web);
		}
		
		dislayDiv();
    	$(".Cube script").each(function( index ) { $(this).attr('src',$(this).attr('data-src')); }); 
       
     $.get("/Resources/englishjagran/misc/detaildata.html?ver=2804206", function (data) { 
      $(".appendToThis").append(data);  
	  $('body').attr('id', 'jagrancss'); 
	  }); 
	  $( document).ready(function() {       
		$( ".articleBody iframe" ).each(function( index ) {
		 $(this).attr('src',$(this).attr('data-src'));
		}); 
      }); 
	   /* stickyRhs(); */
	  isScrolled=1; 
    }
            }  
            resolve(1);
        }
    }); 
}
 $( document).ready(function() {       
		$( ".articleBody script" ).each(function( index ) {
		 $(this).attr('src',$(this).attr('data-src'));
		}); 
  });
</script></div>
<!--ls:end[component-1556360439808]-->
</div>
<div class="ls-cmp-wrap" id="w1637839483963">
<!--ls:begin[component-1637839483963]-->
<div class="iw_component" id="1637839483963"><script>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</script></div>
<!--ls:end[component-1637839483963]-->
</div>
</div>
</div>
<div class="ls-row-clr"></div>
</div>
</div>
</div><script>(function(src) { var a = document.createElement("script");a.type = "text/javascript"; a.async = true; a.src = src;var b = document.getElementsByTagName("script")[0];b.parentNode.insertBefore(a, b) })("https://experience-ap.piano.io/xbuilder/experience/load?aid=PqIxdC0cpj");</script> <script>tp = window["tp"] || [];tp.push(["setContentCreated", "2022-04-02T07:59:57+05:30"]);tp.push(["setContentAuthor","Mallika Mehzabeen"]);tp.push(["setContentSection", "Article Detail Page"]);tp.push(["setTags",["articleDetailPage"]]);tp.push(["setContentIsNative", "false"]);tp.push(["setZone", "Web"]);</script><!--ls:end[body]--><!--ls:begin[page_track]--><!--ls:end[page_track]--></body>
</html>
